Intercom currently down
Incident Report for Swat.io
Resolved
This incident has been resolved.
Posted Nov 12, 2019 - 16:06 CET
Identified
Intercom is currently down, they are currently investigating.
Posted Nov 12, 2019 - 15:59 CET
This incident affected: Intercom (Intercom Web Messenger).